Bean's Place Forums
   Bean's Support and Announcements
    Register Arcade  •  FAQ  •  Search  •  Login     
It is currently Mon May 29, 2017 9:08 am

All times are UTC + 10 hours [ DST ]



Welcome
Welcome to bean

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Config files not in portable file location
PostPosted: Fri Jul 03, 2015 6:08 am 
Offline

Joined: Fri Jul 03, 2015 4:14 am
Posts: 5
Hi,

Config Autover 2.2.1 windows8.1 64bit

Hi I installed this for the first time and specified to put the program in D:\StandAlone\AutoVer and selected:

Install AutoVer as Windows Service
Start AutoVer
AutoVer (already selected)

This installed and ran ok and I set up a watched folder however the AutoVer config and log files are in c:\ProgramData\Autover not in D:\StandAlone\AutoVer

I went into Application Settings and selected Local/Portable and got the attached error
Image

The Reason I went for portable is that I have all my data on drive D and I have a clone of the system drive C which I recover whenever I suspect I have inadvertently installed some malware so when I recover my system image I am back up and running without having to recover changed configs etc as they are all stored on my D drive


Top
 Profile  
 
 Post subject: Re: Config files not in portable file location
PostPosted: Fri Jul 03, 2015 7:04 am 
Offline

Joined: Fri Jul 03, 2015 4:14 am
Posts: 5
On further investigation if I:-
Stop autover
copy the contents of c:\ProgramData\AutoVer to D:\StandAlone\AutoVer

rename c:\ProgramData\AutoVer to c:\ProgramData\AutoVer-org

edit D:\StandAlone\AutoVer\autover.ini
and change
ConfigFolder=COMMON
to
ConfigFolder=D:\StandAlone\AutoVer

Restart autover

I now only get one file in
c:\ProgramData\AutoVer

called AutoVerServiceLog.txt
with an entry of
2015-07-02 20:53:50.599 T15 Warn Error loading config: Could not find file 'C:\ProgramData\AutoVer\AutoVer.xml'.

should I be worried about error?

my watched folder shows up and looks correct and detects changes

Or is there an easier way to go about setting up autover portable?

Thanks in advance


Top
 Profile  
 
 Post subject: Re: Config files not in portable file location
PostPosted: Fri Jul 03, 2015 9:39 am 
Offline

Joined: Fri Jul 03, 2015 4:14 am
Posts: 5
More progress
Installed on another system this time did not opt to start as a windows service also installed winmerge so now when I go into application settings I can select Local/Portable and apply.

I suppose I should have checked the error message more closely instead of assuming that the default application settings would work

I am now getting the following error:-
2015-07-02 21:36:12.764 T1 Error ZoneStripper.Unblock Could not find a part of the path 'C:\Program Files\AutoVer'.
but everything appears to be working


Top
 Profile  
 
 Post subject: Re: Config files not in portable file location
PostPosted: Sat Jul 04, 2015 1:22 am 
Offline

Joined: Fri Jul 03, 2015 4:14 am
Posts: 5
Just creating 'C:\Program Files\AutoVer' stops the ZoneStripper error.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC + 10 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
suspicion-preferred